b62a23c6c7
- Use DISTVERSION - Add most configuration in OPTIONS - Enable support to libedit in sftp [1] - Add OPTIONS to HPN patches [2] - Add new rc.d script [3] - New rc.d script are responsible to check configuration and create host keys - Using USE_RC_SUBR - Modify pkg-message to reflect new rc.d script - Fix pkg-plist Reviewd by: dougb [3] Submitted by: vs [1], brooks [2] Tested by: me, John E Hein
19 lines
458 B
Diff
19 lines
458 B
Diff
--- gss-serv.c.orig Sat Nov 5 02:07:05 2005
|
|
+++ gss-serv.c Thu Feb 2 22:45:37 2006
|
|
@@ -134,6 +134,16 @@
|
|
OM_uint32 offset;
|
|
OM_uint32 oidl;
|
|
|
|
+#if defined(HEIMDAL)
|
|
+ if (strcmp(heimdal_version, "Heimdal 0.6") < 0) {
|
|
+ name->length = ename->length;
|
|
+ name->value = xmalloc(name->length+1);
|
|
+ memcpy(name->value,ename->value,name->length);
|
|
+ ((char *)name->value)[name->length] = 0;
|
|
+ return GSS_S_COMPLETE;
|
|
+ }
|
|
+#endif
|
|
+
|
|
tok = ename->value;
|
|
|
|
/*
|