* Under the hood runs Chromium 87.0.4280.144 with security fixes up to
version 96.0.4664.110 and patches were taken from of www/chromium
87.0.4280.141 (391acded85
).
* Prune some unneeded patches (mostly from the headless and unittest
areas) and try to align the unbundling of dependencies similar to
qt6-webengine for consistency.
* Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles
has changed since Qt 5.15.3.
Tested by: tcberner
Differential Revision: https://reviews.freebsd.org/D38165
37 lines
1.5 KiB
Text
37 lines
1.5 KiB
Text
--- mkspecs/features/functions.prf.orig 2021-12-15 16:12:54 UTC
|
|
+++ mkspecs/features/functions.prf
|
|
@@ -84,6 +84,10 @@ defineReplace(gnWebEngineArgs) {
|
|
include($$QTWEBENGINE_ROOT/src/buildtools/config/windows.pri)
|
|
include($$QTWEBENGINE_ROOT/src/core/config/windows.pri)
|
|
}
|
|
+ freebsd {
|
|
+ include($$QTWEBENGINE_ROOT/src/buildtools/config/freebsd.pri)
|
|
+ include($$QTWEBENGINE_ROOT/src/core/config/linux.pri)
|
|
+ }
|
|
isEmpty(gn_args): error(No gn_args found please make sure you have valid configuration.)
|
|
return($$gn_args)
|
|
}
|
|
@@ -93,6 +97,7 @@ defineReplace(gnPdfArgs) {
|
|
macos: include($$QTWEBENGINE_ROOT/src/buildtools/config/mac_osx.pri)
|
|
ios: include($$QTWEBENGINE_ROOT/src/pdf/config/ios.pri)
|
|
win32: include($$QTWEBENGINE_ROOT/src/buildtools/config/windows.pri)
|
|
+ freebsd: include($$QTWEBENGINE_ROOT/src/buildtools/config/freebsd.pri)
|
|
include($$QTWEBENGINE_ROOT/src/pdf/config/common.pri)
|
|
isEmpty(gn_args): error(No gn_args found please make sure you have valid configuration.)
|
|
return($$gn_args)
|
|
@@ -107,6 +112,7 @@ defineReplace(gnArch) {
|
|
contains(qtArch, "mips"): return(mipsel)
|
|
contains(qtArch, "mips64"): return(mips64el)
|
|
contains(qtArch, "mips64el"): return(mips64el)
|
|
+ contains(qtArch, "power64"): return(ppc64)
|
|
return(unknown)
|
|
}
|
|
|
|
@@ -114,6 +120,7 @@ defineReplace(gnOS) {
|
|
macos: return(mac)
|
|
win32: return(win)
|
|
linux: return(linux)
|
|
+ freebsd: return(freebsd)
|
|
error(Unsupported platform)
|
|
return(unknown)
|
|
}
|