freebsd-ports/www/qt5-webengine/files/patch-src_3rdparty_chromium_base_cpu.h
Kai Knoblich 8067206f03 www/qt5-webengine: Update to 5.15.8
* Under the hood runs Chromium 87.0.4280.144 with security fixes up to
  version 96.0.4664.110 and patches were taken from of www/chromium
  87.0.4280.141 (391acded85).

* Prune some unneeded patches (mostly from the headless and unittest
  areas) and try to align the unbundling of dependencies similar to
  qt6-webengine for consistency.

* Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles
  has changed since Qt 5.15.3.

Tested by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D38165
2023-03-06 05:33:32 +01:00

20 lines
908 B
C++

--- src/3rdparty/chromium/base/cpu.h.orig 2021-12-15 16:12:54 UTC
+++ src/3rdparty/chromium/base/cpu.h
@@ -73,7 +73,7 @@ class BASE_EXPORT CPU final {
IntelMicroArchitecture GetIntelMicroArchitecture() const;
const std::string& cpu_brand() const { return cpu_brand_; }
-#if defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_ANDROID) || \
+#if defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_ANDROID) || defined(OS_BSD) || \
defined(OS_AIX)
enum class CoreType {
kUnknown = 0,
@@ -124,7 +124,7 @@ class BASE_EXPORT CPU final {
// cpuidle driver.
using CoreIdleTimes = std::vector<TimeDelta>;
static bool GetCumulativeCoreIdleTimes(CoreIdleTimes&);
-#endif // defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_ANDROID) ||
+#endif // defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_ANDROID) || defined(OS_BSD)
// defined(OS_AIX)
private: