* Under the hood runs Chromium 87.0.4280.144 with security fixes up to
version 96.0.4664.110 and patches were taken from of www/chromium
87.0.4280.141 (391acded85
).
* Prune some unneeded patches (mostly from the headless and unittest
areas) and try to align the unbundling of dependencies similar to
qt6-webengine for consistency.
* Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles
has changed since Qt 5.15.3.
Tested by: tcberner
Differential Revision: https://reviews.freebsd.org/D38165
11 lines
409 B
Text
11 lines
409 B
Text
--- src/3rdparty/chromium/sandbox/BUILD.gn.orig 2021-12-15 16:12:54 UTC
|
|
+++ src/3rdparty/chromium/sandbox/BUILD.gn
|
|
@@ -27,7 +27,7 @@ group("sandbox") {
|
|
"//sandbox/mac:system_services",
|
|
"//sandbox/mac/mojom",
|
|
]
|
|
- } else if (is_linux || is_chromeos || is_android) {
|
|
+ } else if ((is_linux || is_chromeos || is_android) && !is_bsd) {
|
|
public_deps = [ "//sandbox/linux:sandbox" ]
|
|
}
|
|
}
|