- Add USES=libtool - Eliminate security/openvas-libraries/Makefile.common - Use /var instead of PREFIX/openvas - Remove $FreeBSD$ from patches security/openvas-client: - Add missing dependencies - Add NLS option - Delete old patches
11 lines
435 B
Text
11 lines
435 B
Text
--- libopenvas/Makefile.orig
|
|
+++ libopenvas/Makefile
|
|
@@ -48,7 +48,7 @@
|
|
CFLAGS+=-g -Wall
|
|
INCLUDE = $(include) $(GLIB_CFLAGS) $(DEFS) -I../libopenvascommon
|
|
CIPHER = -I../$(CIPHER_SUBDIR)
|
|
-COMPILE = $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS)
|
|
+COMPILE = $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS)
|
|
LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
|
|
all : libopenvas.la
|
|
|