freebsd-ports/cad/klayout/files/patch-src-Makefile.rules
Hiroki Sato 7793071175 Update to 0.14. Changes since version 0.10 include:
* Several RBA extensions: i.e. alternative methods replacing
   different 'new' variants by one 'new'. Markers now can be
   filled.

 * Fixes for the bugs mentioned in the issues list.

 * OASIS and GDS writing capabilities. Menu functions are
   provided to save a layout and single cells as well as RBA
   extensions that allow to write a layout. See Saving a layout
   or parts of it for details.

 * Rulers and markers are drawn with a thin halo in background
   color to enhance their visibility. This can be switched off in
   the setup dialog if this is not desired. The following
   screenshots illustrate the differences:

 * A couple of RBA extensions: API's for shape properties, rulers
   and geometry selections.

 * A bugfix for the OASIS reader (sometimes crashing the reader
   on CBLOCK-compressed input)

 * A function to descend into a cell in the hierarchy but keeping
   the context, which is shown in dimmed colors. This function
   can be found in the "Display" menu and is called "Descend". To
   use this function, select a shape or instance inside the cell
   into which to descend. "Descend" then enters the next cell
   along the path that leads to the selected shape or instance.

 * The mouse wheel can be used to zoom in and out.

 * Shift+right mouse button pressed now allows to "drag" layout
   in a "Google maps" fashion.

 * Copy & paste now is available for layers as well.

 * A ruby console is provided where ruby commands can be executed
   interactively.

 * The way how the selection is displayed can be configured
   now (color, line width and vertex size).

 * The interrupt signal now is enabled again even if Ruby is
   activated (Ctrl+C now works again).

 * Support for arbitrary angles on cell instances.

 * A bugfix for the OASIS reader (CTRAPEZOIDS have not been read
   in some cases). The OASIS reader now uses shape arrays to
   acchieve are smaller memory footprint in some cases.

 * Multiple transformations are now allowed on layer source
   expressions (see Transforming views and property selectors for
   a detailed description).

 * Rulers now are configurable to a large extent. Multiple ruler
   templates may be defined from which a certain ruler type can
   be choosen. Some of the new ruler styles are no
   longer "rulers" but rather "annotations". See Ruler properties
   for a description of that feature.

 * Last, but not least: KLayout now can be scripted to some
   extend using Ruby as the scripting language. For more
   information about this feature, see RBA introduction.

 * Some bugs were fixed in the OASIS implementation. CBLOCK
   compression now is supported. Forward cell name
   references (numerical ID is used before being associated with
   a string) are supported as now. File global properties are now
   read correctly. A bug reading certain CTRAPEZOID objects was
   fixed.
   (Still, forward references are not allowed for text/property
   strings or property names).

 * A layout properties dialog has been added that shows basic
   properties of the layout such as top cells, layers and others.

 * The "Select Cell" dialog has been enhanced with the capability
   to hide and show multiple cells in the cell list.

 * A "zoom fit" mouse gesture was implemented: moving the mouse
   up and right with the right mouse button pressed now fits the
   current cell into the window. Moving up and left still zooms
   out.

 * A bug in the GDS2 reader, dropping polygon points in rare
   cases, was fixed
2008-05-05 16:08:43 +00:00

13 lines
320 B
Text

--- src/Makefile.rules.orig Fri Nov 9 04:31:39 2007
+++ src/Makefile.rules Sun Jan 6 18:59:35 2008
@@ -25,8 +25,8 @@
CCOPTS=$(CCWARN) $(DEFS) $(CCOPT)
CCOPTS_DEP=$(DEFS) $(CCOPT_DEP)
-MOC=$(QTBIN)/moc
-UIC=$(QTBIN)/uic
+MOC=$(QTBIN)/moc-qt4
+UIC=$(QTBIN)/uic-qt4
RCC=$(QTBIN)/rcc
# this target must be first: