freebsd-ports/math/proofgeneral/files/patch-doc-Makefile.doc
Alex Kozlov f47f91d2a0 - Fix build with new texi2html
- Ignore attempts to compile with XEmacs, it is not supported by the ProofGeneral developers.

PR:	ports/169774
Submitted by:	Timothy Beyer <beyert@cs.ucr.edu> (maintainer)
2012-07-12 14:05:30 +00:00

75 lines
1.8 KiB
Text

--- doc/Makefile.doc.orig 2011-05-05 10:46:27.000000000 -0700
+++ doc/Makefile.doc 2012-07-10 15:19:30.000000000 -0700
@@ -18,7 +18,7 @@
MAKE = make -f Makefile.doc
MAKEINFO = makeinfo
-TEXI2HTML = texi2html -expandinfo -number -split_chapter --noheader
+TEXI2HTML = texi2html -expandinfo -number-sections -split_chapter --noheader
# `texinfo-tex' package contains texi2pdf
TEXI2PDF = texi2pdf
# `dviutils' package contains these useful utilities.
@@ -40,16 +40,13 @@
TMPFILE=pgt
-.SUFFIXES: .texi .info .html .pdf .gz
+.SUFFIXES: .texi .info .html .gz
default: doc
.texi.info:
$(MAKEINFO) $<
-.texi.pdf:
- $(TEXI2PDF) $<
-
.texi.html:
$(TEXI2HTML) --output $* $<
@@ -61,21 +58,19 @@
gzip -f -9 $*
##
-## doc : build pdf, info files from $(DOCNAME).texi
+## doc : build info files from $(DOCNAME).texi
##
-doc: pdf info
+doc: info
##
## all : build all documentation targets
##
-all: html info pdf
+all: html info
##
## dist: build distribution targets
##
-dist: info html pdf
-
-pdf: $(DOCNAME).pdf
+dist: info html
# da: target is a fake: we actually make in a subdir
html: $(DOCNAME).html
@@ -97,18 +92,13 @@
## distclean: Remove documentation targets
##
distclean: clean
- rm -rf $(DOCNAME).info* $(DOCNAME).pdf $(DOCNAME)
+ rm -rf $(DOCNAME).info* $(DOCNAME)
##
## texi: update magic comments in texi from docstrings in code.
## (developer use only!)
## Must be run from source .els otherwise function arguments lost
##
-$(DOCNAME).texi:
- $(MAKE) magic
-magic:
- (cd ..; make clean)
- $(EMACS) $(EMACSFLAGS) -batch -l ./docstring-magic.el $(DOCNAME).texi -f texi-docstring-magic -f save-buffer
debugmagic:
$(EMACS) $(EMACFLAGS) -eval '(setq debug-on-error t)' -l ./docstring-magic.el $(DOCNAME).texi -f texi-docstring-magic -f save-buffer