freebsd-ports/lang/gcc47-aux/files/diff-gcc-testsuite
John Marino c8d1486769 Duplicate port lang/gcc-aux => lang/gcc47-aux
A new version of the Ada compiler is coming imminently.  Not all ports
will immediately build with the gcc49-based compiler, so a few ports
will be directed to use the current compiler in this new location instead.
It will require a change in Uses/ada.mk (upcoming).

Some ports will require updates to use upcoming lang/gcc-aux version.
The last set of ports that will be converted is likely the gnatdroid
ports as these will require a lot of time running testsuites, which takes
some time wirelessly on the Android target.
2014-03-09 18:15:13 +00:00

46 lines
1.6 KiB
Text

--- gcc/testsuite/gcc.dg/pch/pch.exp.orig
+++ gcc/testsuite/gcc.dg/pch/pch.exp
@@ -44,6 +44,8 @@
set test "largefile.c"
set testh "largefile.hs"
set f [open $test w]
+puts $f "/* { dg-do run { target *-*-solaris* } } */"
+puts $f "/* { dg-error \"dummy\" \"fool dejagnu\" { target { ! *-*-solaris* } 20 } } */"
puts $f "/* { dg-timeout-factor 4.0 } */"
set v 0
for { set v 0 } { $v < 10000 } { incr v } {
--- gcc/testsuite/gcc.dg/format/ext-1.c.orig
+++ gcc/testsuite/gcc.dg/format/ext-1.c
@@ -8,7 +8,7 @@
#include "format.h"
void
-foo (quad_t q, u_quad_t uq, quad_t *qn, size_t z, size_t *zn, long long int ll,
+foo (quad2_t q, u_quad2_t uq, quad2_t *qn, size_t z, size_t *zn, long long int ll,
unsigned long long int ull, int i, unsigned int u, double d,
char *s, void *p, wchar_t *ls, wint_t lc, int *n, long int l)
{
--- gcc/testsuite/gcc.dg/format/ext-2.c.orig
+++ gcc/testsuite/gcc.dg/format/ext-2.c
@@ -8,7 +8,7 @@
#include "format.h"
void
-foo (quad_t *qp, u_quad_t *uqp, quad_t *qn, long long int *llp,
+foo (quad2_t *qp, u_quad2_t *uqp, quad2_t *qn, long long int *llp,
unsigned long long int *ullp, float *fp, char *s, void **pp, wchar_t *ls,
int *ip, unsigned int *up)
{
--- gcc/testsuite/gcc.dg/format/format.h.orig
+++ gcc/testsuite/gcc.dg/format/format.h
@@ -71,8 +71,8 @@
#endif
/* %q formats want a "quad"; GCC considers this to be a long long. */
-typedef llong quad_t;
-typedef ullong u_quad_t;
+typedef llong quad2_t;
+typedef ullong u_quad2_t;
__extension__ typedef __INTMAX_TYPE__ intmax_t;
__extension__ typedef __UINTMAX_TYPE__ uintmax_t;