85 lines
2.6 KiB
Text
85 lines
2.6 KiB
Text
--- mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2010-12-07 17:36:07.000000000 +0100
|
|
+++ mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in 2011-02-26 21:30:36.000000000 +0100
|
|
@@ -73,6 +73,9 @@
|
|
DEFINES += -DKEEP_STACK_16_BYTE_ALIGNED
|
|
CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
|
|
endif
|
|
+ifeq (x86_64,$(OS_TEST))
|
|
+CPPSRCS := xptcinvoke_x86_64_linux.cpp xptcstubs_x86_64_linux.cpp
|
|
+endif
|
|
endif
|
|
endif
|
|
|
|
@@ -96,7 +99,7 @@
|
|
endif
|
|
endif
|
|
# IA64 Linux
|
|
-ifneq (,$(filter Linux,$(OS_ARCH)))
|
|
+ifneq (,$(filter Linux FreeBSD,$(OS_ARCH)))
|
|
ifneq (,$(findstring ia64,$(OS_TEST)))
|
|
CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
|
|
ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
|
|
@@ -115,6 +118,12 @@
|
|
CPPSRCS := xptcinvoke_amd64_linux.cpp xptcstubs_amd64_linux.cpp
|
|
endif
|
|
#
|
|
+# FreeBSD/amd64
|
|
+#
|
|
+ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDamd64)
|
|
+CPPSRCS := xptcinvoke_amd64_openbsd.cpp xptcstubs_amd64_openbsd.cpp
|
|
+endif
|
|
+#
|
|
# BeOS/Intel (uses the same unixish_x86 code)
|
|
#
|
|
ifeq ($(OS_ARCH)$(OS_TEST),BeOSBePC)
|
|
@@ -165,9 +174,15 @@
|
|
ASFILES := xptcinvoke_asm_osf1_alpha.s xptcstubs_asm_osf1_alpha.s
|
|
endif
|
|
#
|
|
+# FreeBSD/Alpha
|
|
+#
|
|
+ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDalpha)
|
|
+CPPSRCS := xptcinvoke_freebsd_alpha.cpp xptcstubs_freebsd_alpha.cpp
|
|
+endif
|
|
+#
|
|
# Linux/Alpha
|
|
#
|
|
-ifneq (,$(filter Linuxalpha FreeBSDalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
|
|
+ifneq (,$(filter Linuxalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
|
|
CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
|
|
endif
|
|
#
|
|
@@ -322,7 +337,7 @@
|
|
#
|
|
# Linux/PPC
|
|
#
|
|
-ifeq ($(OS_ARCH)$(OS_TEST),Linuxpowerpc)
|
|
+ifneq (,$(filter Linuxpowerpc FreeBSDpowerpc,$(OS_ARCH)$(OS_TEST)))
|
|
CPPSRCS := xptcinvoke_ppc_linux.cpp xptcstubs_ppc_linux.cpp
|
|
ASFILES := xptcinvoke_asm_ppc_linux.s xptcstubs_asm_ppc_linux.s
|
|
AS := $(CC) -c -x assembler-with-cpp
|
|
@@ -331,7 +346,7 @@
|
|
#
|
|
# Linux/PPC64
|
|
#
|
|
-ifeq ($(OS_ARCH)$(OS_TEST),Linuxpowerpc64)
|
|
+ifneq (,$(filter Linuxpowerpc64 FreeBSDpowerpc64,$(OS_ARCH)$(OS_TEST)))
|
|
CPPSRCS := xptcinvoke_ppc64_linux.cpp xptcstubs_ppc64_linux.cpp
|
|
ASFILES := xptcinvoke_asm_ppc64_linux.s xptcstubs_asm_ppc64_linux.s
|
|
AS := $(CC) -c -x assembler-with-cpp
|
|
@@ -400,6 +415,15 @@
|
|
ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
|
|
endif
|
|
#
|
|
+# FreeBSD/SPARC64
|
|
+#
|
|
+ifeq ($(OS_ARCH),FreeBSD)
|
|
+ifneq (,$(findstring sparc,$(OS_TEST)))
|
|
+CPPSRCS := xptcinvoke_sparc64_openbsd.cpp xptcstubs_sparc64_openbsd.cpp
|
|
+ASFILES := xptcinvoke_asm_sparc64_openbsd.s xptcstubs_asm_sparc64_openbsd.s
|
|
+endif
|
|
+endif
|
|
+#
|
|
# OpenBSD/SPARC
|
|
#
|
|
ifeq ($(OS_ARCH)$(OS_TEST),OpenBSDsparc)
|