- Add master site - Transfer maintainership to games@ team - Remove DEPRECATED, EXPIRATION_DATE - Add USE_GCC=yes - Add DOCS and add Option - Install conditional NLS, add Option - Support STAGEDIR and add OPTIONS_SUB - Use patch instead of REINPLACE, remove setuid executable and change add patch-Makefile.in - Change REINPLACE, cosmetical changes - Fix GNU/Linux compatibility, proper install - Fix desktop entry file - Recreate patch with make makepatch - Change pkg-descr - Change pkg-plist
18 lines
618 B
C
18 lines
618 B
C
--- ./src/anim.c.orig 2004-05-10 12:42:51.000000000 +0200
|
|
+++ ./src/anim.c 2014-04-04 17:49:31.971201127 +0200
|
|
@@ -47,6 +47,7 @@
|
|
Animation newanim;
|
|
char *fullfilename;
|
|
int i;
|
|
+ GError *gerror = NULL;
|
|
|
|
/* Find the number of frames */
|
|
fullfilename = g_strdup_printf("%s.%d.png", filename, 0);
|
|
@@ -64,7 +65,6 @@
|
|
sizeof(GdkPixbuf *));
|
|
for(i = 0; i < newanim.num_frames; i++) {
|
|
fullfilename = g_strdup_printf("%s.%d.png", filename, i);
|
|
- GError *gerror = NULL;
|
|
newanim.pixmaps[i] = gdk_pixbuf_new_from_file(fullfilename,
|
|
&gerror);
|
|
if(!newanim.pixmaps[i]) {
|