freebsd-ports/security/openssh/files/patch-ad
Dirk Meyer bf0a21e0d5 - Update to OpenSSH 2.9.9
- convert portname into lowercase
- PREFIX support for default sshd_config
- security-patch for cookie files obsolete
2001-10-03 13:15:16 +00:00

27 lines
674 B
Text

--- lib/Makefile.orig Mon Sep 24 22:34:07 2001
+++ lib/Makefile Wed Oct 3 13:45:40 2001
@@ -9,10 +9,14 @@
rsa.c tildexpand.c ttymodes.c uidswap.c xmalloc.c atomicio.c \
key.c dispatch.c kex.c mac.c uuencode.c misc.c \
rijndael.c ssh-dss.c ssh-rsa.c dh.c kexdh.c kexgex.c \
- scard.c
+ scard.c strlcpy.c strlcat.c
SRCS+= readpassphrase.c
+.if defined(COMPAT_GETADDRINFO)
+SRCS+= getaddrinfo.c getnameinfo.c name6.c rcmd.c bindresvport.c
+.endif
+
NOPROFILE= yes
NOPIC= yes
@@ -20,6 +24,8 @@
@echo -n
.include <bsd.own.mk>
+IGNORE_LIBSSH=yes
+.include "../Makefile.inc"
.if (${KERBEROS:L} == "yes")
CFLAGS+= -DKRB4 -I${DESTDIR}/usr/include/kerberosIV