981d45c88b
- update sources to 0.6.7 -- the tip of 0.6-series; - reworked patches and grouped them by-commit rather than by-file; - excluded removal of .orig files -- all files aren't installed anymore; - changed maintainer (my) e-mail. Approved by: garga (mentor) PR: ports/151118
45 lines
1.9 KiB
Text
45 lines
1.9 KiB
Text
From cccbb033458f205ac74e11babe5021bc7a3ade3c Mon Sep 17 00:00:00 2001
|
|
From: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
|
|
Date: Wed, 17 Nov 2010 19:47:16 +0300
|
|
Subject: [PATCH 1/3] Do not overwrite configuration files
|
|
|
|
Install all configuration files as *-sample.
|
|
|
|
Signed-off-by: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
|
|
---
|
|
sample-config/Makefile.in | 8 +++-----
|
|
1 files changed, 3 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/sample-config/Makefile.in b/sample-config/Makefile.in
|
|
index 883345c..1eac2c1 100644
|
|
--- a/sample-config/Makefile.in
|
|
+++ b/sample-config/Makefile.in
|
|
@@ -31,14 +31,12 @@ distclean: clean
|
|
devclean: distclean
|
|
|
|
install:
|
|
- -rm -f $(DESTDIR)$(HTMLDIR)/conf/config.php
|
|
-
|
|
$(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)
|
|
$(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/check_commands
|
|
$(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/pages
|
|
$(INSTALL) -m 644 $(INSTALL_OPTS) pnp/pnp4nagios_release $(DESTDIR)$(SYSCONFDIR)
|
|
- $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)
|
|
- $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(SYSCONFDIR)
|
|
+ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)/config.php-sample
|
|
+ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(SYSCONFDIR)/background.pdf-sample
|
|
|
|
install-config:
|
|
|
|
@@ -46,7 +44,7 @@ install-config:
|
|
$(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/check_commands
|
|
$(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/pages
|
|
|
|
- $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)
|
|
+ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)/config.php-sample
|
|
$(INSTALL) -m 644 $(INSTALL_OPTS) pnp/process_perfdata.cfg-sample $(DESTDIR)$(SYSCONFDIR)
|
|
$(INSTALL) -m 644 $(INSTALL_OPTS) pnp/rra.cfg-sample $(DESTDIR)$(SYSCONFDIR)
|
|
$(INSTALL) -m 644 $(INSTALL_OPTS) misccommands.cfg-sample $(DESTDIR)$(SYSCONFDIR)
|
|
--
|
|
1.7.2.1
|
|
|