freebsd-ports/security/sasp/files/patch-Makefile
Pav Lucistnik eb81a88093 - Patch net/libnet* to versioned libraries and header files, so they can
coexist

PR:		ports/103861
Submitted by:	alepulver
Tested by:	pointyhat
With hat:	portmgr
2007-01-31 14:09:55 +00:00

11 lines
384 B
Text

--- ./Makefile.orig Thu Apr 7 06:33:45 2005
+++ ./Makefile Wed Sep 27 22:46:49 2006
@@ -1,6 +1,6 @@
all:
- cc -o sasp sasp.c -L/usr/local/lib -I/usr/local/include -lpcap -lnet
+ ${CC} `${LIBNET_CONFIG} --cflags` -o sasp sasp.c -lpcap `${LIBNET_CONFIG} --libs`
install:
- install -o root -m 555 sasp /usr/local/sbin
+ ${BSD_INSTALL_PROGRAM} sasp ${PREFIX}/sbin
clean:
rm -rf *.o