freebsd-ports/multimedia/vdr-plugin-ttxtsubs/files/patch-Makefile
Juergen Lock 47452dcb43 - Finally stagify the vdr ports. \o/
- Use new LIB_DEPENDS syntax.
- Change multimedia/vdr-plugins defaults and bump PORTREVISION for it.
  (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
2014-03-01 12:21:13 +00:00

21 lines
625 B
Text

--- a/Makefile
+++ b/Makefile
@@ -101,7 +101,11 @@ all: libvdr-$(PLUGIN).so i18n
libvdr-$(PLUGIN).so: $(OBJS)
$(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+ifdef FREEBSD
+ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
+else
@cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
+endif
dist: $(I18Npo) clean
@-rm -rf $(TMPDIR)/$(ARCHIVE)
@@ -114,3 +118,6 @@ dist: $(I18Npo) clean
clean:
@-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
@-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
+
+install:
+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)