freebsd-ports/www/mitmproxy/files/patch-setup.py
Wesley Shields c63bafd09f 'mitmproxy' is an SSL-capable man-in-the-middle HTTP proxy. It provides a
console interface that allows traffic flows to be inspected and edited on the
fly.

'mitmdump' is the command-line version of mitmproxy, with the same
functionality but without the frills. Think tcpdump for HTTP.

WWW: http://mitmproxy.org/index.html

PR:		ports/173449
Submitted by:	Hung-Yi Chen <gaod@hychen.org>
Feature safe:	yes
2012-11-24 20:01:26 +00:00

14 lines
467 B
Python

--- setup.py.orig 2012-04-09 11:55:00.000000000 +0800
+++ setup.py 2012-11-08 01:43:57.000000000 +0800
@@ -1,4 +1,5 @@
from distutils.core import setup
+from setuptools import setup
import fnmatch, os.path
from libmproxy import version
@@ -92,5 +93,4 @@
"Topic :: Internet :: Proxy Servers",
"Topic :: Software Development :: Testing"
],
- install_requires=['urwid>=1.0', 'pyasn1', 'pyopenssl>=0.12', "PIL", "lxml"],
)