freebsd-ports/editors/e93/files/patch-machdef.mk
Martin Wilke 3e4ed01146 - Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
	Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
	ehaupt, nox, itetcu, flz, pav

PR:		116263
Tested on:	pointyhat
Approved by:	portmgr (pav)
2008-04-19 17:56:05 +00:00

44 lines
1.2 KiB
Makefile

--- machdef.mk.orig Fri Sep 29 02:47:44 2000
+++ machdef.mk Fri Sep 29 02:50:54 2000
@@ -27,33 +27,32 @@
#
# e93 will install its single executable "e93" in $PREFIX/bin
# and it will place a directory called "e93lib" in $PREFIX/lib
-PREFIX=/usr/local
# The following lines may need to be altered if the Tcl
# files are located elsewhere on your system:
-TCL_INCLUDE=-I/usr/local/include
-TCL_LIB=-L/usr/local/lib
+TCL_INCLUDE=-I${LOCALBASE}/include/tcl8.4
+TCL_LIB=-L${LOCALBASE}/lib
# uncomment and change if you want to link with specific versions of Tcl/Tk
-#TCL_VERSION=8.3
+TCL_VERSION=84
+TK_INCLUDE=-I${LOCALBASE}/include/tk8.4
# The following lines may need to be altered if the X include and library
# files are located elsewhere on your system:
-X_INCLUDE=-I/usr/X11R6/include
-X_LIB=-L/usr/X11R6/lib
+X_INCLUDE=-I${LOCALBASE}/include
+X_LIB=-L${LOCALBASE}/lib
# if your system needs some extra libraries, add them here:
-EXTRALIBS=-lm -ldl
+EXTRALIBS=-lm
# Uncomment this line if running Solaris:
#MACHINESPEC=-DSOLARIS
# set compiler to use
-CC=gcc
# set some compiler options
-OPTIONS=-O2 -Wall -x c++ -g
+OPTIONS=-Wall -x c++
#OPTIONS = -Wall -O2 -x c++ -mcpu=21164a -Wa,-m21164a -g