copy. This should have the following effects: . Fix problems experienced by programmes that dynamically create their own copy of the JVM and are linked against the system's zlib (e.g., eclipse). . Reduce the potential for zlib based security problems affecting the JDK. This is similar to the patch in the PR, but was actually backported from the patches for the jdk15 port, so its a touch different. PR: 92459
31 lines
690 B
Text
31 lines
690 B
Text
--- ../../j2se/make/java/zip/Makefile.orig Wed Sep 10 19:43:01 2003
|
|
+++ ../../j2se/make/java/zip/Makefile Sat Feb 11 00:55:54 2006
|
|
@@ -12,8 +12,6 @@
|
|
PRODUCT = sun
|
|
include $(BUILDDIR)/common/Defs.gmk
|
|
|
|
-ZLIB_VERSION = 1.1.3
|
|
-
|
|
#
|
|
# Files to compile.
|
|
#
|
|
@@ -58,13 +56,6 @@
|
|
CPPFLAGS += -UDEBUG
|
|
endif
|
|
|
|
-CPPFLAGS += -I$(SHARE_SRC)/native/java/util/zip/zlib-$(ZLIB_VERSION)
|
|
-
|
|
-#
|
|
-# Add to ambient vpath so we pick up the library files
|
|
-#
|
|
-vpath %.c $(SHARE_SRC)/native/$(PKGDIR)/zlib-$(ZLIB_VERSION)
|
|
-
|
|
#
|
|
# Has been converted to the JNI: generate JNI-style header files
|
|
#
|
|
@@ -73,4 +64,4 @@
|
|
#
|
|
# Link to JVM library for JVM_Zip* functions
|
|
#
|
|
-OTHER_LDLIBS = $(JVMLIB)
|
|
+OTHER_LDLIBS = -lz
|