freebsd-ports/textproc/splitpatch/files/patch-man_pod2man.mk
Emanuel Haupt f170eab3c6 A utility to split a diff patch into separate sections. It also features
splitting a patch file by hunks instead of the default by file. This is very
useful for merging patches that fail to apply by only some hunks.

WWW: https://github.com/benjsc/splitpatch
2016-12-29 12:59:31 +00:00

33 lines
812 B
Makefile

--- man/pod2man.mk.orig 2016-08-15 17:36:10 UTC
+++ man/pod2man.mk
@@ -36,7 +36,6 @@ RELEASE ?= $(PACKAGE)
# Optional variables to set
MANSECT ?= 1
-PODCENTER ?= $$(date "+%Y-%m-%d")
# Directories
MANSRC =
@@ -46,7 +45,6 @@ MANPOD = $(MANSRC)$(PACKAGE).$(MANSECT)
MANPAGE = $(MANDEST)$(PACKAGE).$(MANSECT)
POD2MAN = pod2man
-POD2MAN_FLAGS = --utf8
makeman: $(MANPAGE)
@@ -54,12 +52,9 @@ $(MANPAGE): $(MANPOD)
# make target - create manual page from a *.pod page
podchecker $(MANPOD)
LC_ALL=C $(POD2MAN) $(POD2MAN_FLAGS) \
- --center="$(PODCENTER)" \
+ --center=" " \
--name="$(PACKAGE)" \
--section="$(MANSECT)" \
--release="$(RELEASE)" \
$(MANPOD) \
- > $(MANPAGE) && \
- rm -f pod*.tmp
-
-# End of of Makefile part
+ > $(MANPAGE)