freebsd-ports/games/BillardGL/files/patch-Makefile
Steve Wills 536d0f01c8 - Improve COMMENT
- Set LICENSE
- Use DOS2UNIX where appropriate
- Use PLIST_FILES instead of pkg-plist due to short plist
- Convert OptionsNG
- Give maintainership to submitter

PR:		ports/171317
Submitted by:	nemysis <nemysis@gmx.ch>
2012-09-10 20:48:10 +00:00

24 lines
610 B
Text

--- Makefile.orig Sat Jan 3 16:30:14 2004
+++ Makefile Sat Jan 3 16:32:08 2004
@@ -5,14 +5,14 @@
####### Compiler, tools and options
-CC = gcc
-CXX = g++
-CFLAGS = -pipe -Wall -W -DNO_DEBUG -g
-CXXFLAGS= -pipe -Wall -W -DNO_DEBUG -g
-INCPATH = -I/usr/X11R6/include
-LINK = g++
+CC ?= gcc
+CXX ?= g++
+CFLAGS ?= -pipe -Wall -W -DNO_DEBUG
+CXXFLAGS?= -pipe -Wall -W -DNO_DEBUG
+INCPATH = -I${LOCALBASE}/include
+LINK = ${CXX}
LFLAGS =
-LIBS = -L/usr/X11R6/lib -lGL -lGLU -lglut -lXmu -lXext -lX11 -lm -lXi
+LIBS = -L${LOCALBASE}/lib -lGL -lGLU -lglut -lXmu -lXext -lX11 -lm -lXi
## -lqgl -lGLU