76 lines
2.3 KiB
Text
76 lines
2.3 KiB
Text
--- mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2011-05-28 15:26:21.000000000 +0200
|
|
+++ mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in 2011-06-03 18:39:42.769434047 +0200
|
|
@@ -74,6 +74,9 @@
|
|
# NOTE: MODULE_OPTIMIZE_FLAGS must be set before including config.mk
|
|
MODULE_OPTIMIZE_FLAGS=-O3
|
|
endif
|
|
+ifeq (x86_64,$(OS_TEST))
|
|
+CPPSRCS := xptcinvoke_x86_64_linux.cpp xptcstubs_x86_64_linux.cpp
|
|
+endif
|
|
endif
|
|
endif
|
|
|
|
@@ -117,7 +120,7 @@
|
|
endif
|
|
endif
|
|
# IA64 Linux
|
|
-ifneq (,$(filter Linux,$(OS_ARCH)))
|
|
+ifneq (,$(filter Linux FreeBSD,$(OS_ARCH)))
|
|
ifneq (,$(findstring ia64,$(OS_TEST)))
|
|
CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
|
|
ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
|
|
@@ -129,6 +132,12 @@
|
|
ifeq ($(OS_ARCH)$(OS_TEST),OpenBSDx86_64)
|
|
CPPSRCS := xptcinvoke_amd64_openbsd.cpp xptcstubs_amd64_openbsd.cpp
|
|
endif
|
|
+# FreeBSD/amd64
|
|
+#
|
|
+ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDamd64)
|
|
+CPPSRCS := xptcinvoke_amd64_openbsd.cpp xptcstubs_amd64_openbsd.cpp
|
|
+endif
|
|
+#
|
|
#
|
|
# Neutrino/Intel (uses the same unixish_x86 code)
|
|
#
|
|
@@ -184,9 +193,15 @@
|
|
ASFILES := xptcinvoke_asm_osf1_alpha.s xptcstubs_asm_osf1_alpha.s
|
|
endif
|
|
#
|
|
+# FreeBSD/Alpha
|
|
+#
|
|
+ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDalpha)
|
|
+CPPSRCS := xptcinvoke_freebsd_alpha.cpp xptcstubs_freebsd_alpha.cpp
|
|
+endif
|
|
+#
|
|
# Linux/Alpha
|
|
#
|
|
-ifneq (,$(filter Linuxalpha FreeBSDalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
|
|
+ifneq (,$(filter Linuxalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
|
|
CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
|
|
endif
|
|
#
|
|
@@ -341,7 +356,7 @@
|
|
#
|
|
# Linux/PPC
|
|
#
|
|
-ifeq ($(OS_ARCH)$(OS_TEST),Linuxpowerpc)
|
|
+ifneq (,$(filter Linuxpowerpc FreeBSDpowerpc,$(OS_ARCH)$(OS_TEST)))
|
|
CPPSRCS := xptcinvoke_ppc_linux.cpp xptcstubs_ppc_linux.cpp
|
|
ASFILES := xptcinvoke_asm_ppc_linux.s xptcstubs_asm_ppc_linux.s
|
|
AS := $(CC) -c -x assembler-with-cpp
|
|
@@ -419,6 +434,15 @@
|
|
ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
|
|
endif
|
|
#
|
|
+# FreeBSD/SPARC64
|
|
+#
|
|
+ifeq ($(OS_ARCH),FreeBSD)
|
|
+ifneq (,$(findstring sparc,$(OS_TEST)))
|
|
+CPPSRCS := xptcinvoke_sparc64_openbsd.cpp xptcstubs_sparc64_openbsd.cpp
|
|
+ASFILES := xptcinvoke_asm_sparc64_openbsd.s xptcstubs_asm_sparc64_openbsd.s
|
|
+endif
|
|
+endif
|
|
+#
|
|
# OpenBSD/SPARC
|
|
#
|
|
ifeq ($(OS_ARCH)$(OS_TEST),OpenBSDsparc)
|