freebsd-ports/lang/gnatdroid-armv5/files/patch-gcc__Makefile.in
Frederic Culot 6d05a639a7 The gnatdroid-armv5 port builds a C/Ada cross-compiler based on GCC 4.6 that
targets the Android operating system (version 2.3, API level 9) running on
ARM architecture (version 5).  This produces binaries that run natively on
Android devices as well as the Android SDK emulator.

WWW: http://www.dragonlace.net

PR:		ports/160426
Submitted by:	John Marino <freebsdml@marino.st>
2011-09-07 05:22:05 +00:00

27 lines
817 B
Text

--- gcc/Makefile.in.orig 2011-01-09 00:44:20.000000000 +0100
+++ gcc/Makefile.in 2011-01-09 00:53:28.000000000 +0100
@@ -306,11 +306,11 @@
# This is where we get zlib from. zlibdir is -L../zlib and zlibinc is
# -I../zlib, unless we were configured with --with-system-zlib, in which
# case both are empty.
-ZLIB = @zlibdir@ -lz
+ZLIB = -Wl,-Bstatic @zlibdir@ -lz -Wl,-Bdynamic
ZLIBINC = @zlibinc@
# How to find GMP
-GMPLIBS = @GMPLIBS@
+GMPLIBS = -Wl,-Bstatic @GMPLIBS@ -Wl,-Bdynamic
GMPINC = @GMPINC@
# How to find PPL
@@ -626,8 +626,8 @@
LIBINTL_DEP = @LIBINTL_DEP@
# Character encoding conversion library.
-LIBICONV = @LIBICONV@
-LIBICONV_DEP = @LIBICONV_DEP@
+LIBICONV = -Wl,-Bstatic -L/usr/local/lib -liconv -Wl,-Bdynamic
+LIBICONV_DEP =
# The GC method to be used on this system.
GGC=@GGC@.o