46 lines
1.4 KiB
Text
46 lines
1.4 KiB
Text
--- examples/Makefile.orig Wed Jul 4 13:23:28 2007
|
|
+++ examples/Makefile Wed Jul 4 23:23:43 2007
|
|
@@ -38,10 +38,10 @@
|
|
# Set correct variables and paths
|
|
#---------------------------------
|
|
CIMG_VERSION = 1.22
|
|
-CC = g++
|
|
-X11PATH = /usr/X11R6
|
|
-CFLAGS = -Wall -W -ansi -pedantic -ffast-math
|
|
-LDFLAGS = -lm -lpthread
|
|
+CC = $(CXX)
|
|
+#X11PATH = /usr/X11R6
|
|
+#CFLAGS = -Wall -W -ansi -pedantic -ffast-math
|
|
+#LDFLAGS = -lm -lpthread
|
|
|
|
#--------------------------------------------------
|
|
# Set compilation flags allowing to customize CImg
|
|
@@ -77,6 +77,9 @@
|
|
# Flags to compile on Solaris
|
|
CIMG_SOLARIS_FLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
|
|
|
|
+# Flags to compile on FreeBSD
|
|
+CIMG_FREEBSD_FLAGS = -ansi -ffast-math -I$(X11PATH)/include $(EXTRA_FLAGS) -lX11 -L$(X11PATH)/lib
|
|
+
|
|
# Set default compilation flags.
|
|
# Uncomment lines here, if you want to customize your default configuration
|
|
CIMG_DEFAULT_FLAGS = $(CIMG_X11_FLAGS) \
|
|
@@ -130,7 +133,7 @@
|
|
all: $(CIMG_FILES)
|
|
|
|
clean:
|
|
- rm -f *.exe *~ $(CIMG_FILES)
|
|
+ rm -f *.exe *~ $(CIMG_FILES) Makefile.orig
|
|
|
|
# Linux/Mac OSX targets
|
|
linux:
|
|
@@ -156,3 +159,9 @@
|
|
Msolaris:
|
|
make "ARCHFLAGS=-Dcimg_display_type=0 -O3 $(CIMG_ALL_FLAGS)" all
|
|
|
|
+# FreeBSD targets
|
|
+dFreeBSD:
|
|
+ make "ARCHFLAGS=$(CIMG_FREEBSD_FLAGS) $(CIMG_DEFAULT_FLAGS)" all
|
|
+
|
|
+oFreeBSD:
|
|
+ make "ARCHFLAGS=$(CIMG_FREEBSD_FLAGS) $(CIMG_ALL_FLAGS)" all
|