4fbc32fd37
host panics - longer explanation in this post: http://docs.freebsd.org/cgi/mid.cgi?20080501101951.GA30274 [1] - Get rid of superfluous "kqemu " in IGNORE message when kernel source is missing - Pass down DEBUG_FLAGS to the build - Bump PORTREVISION PR: ports/113430 [1]
22 lines
665 B
Text
22 lines
665 B
Text
Index: common/Makefile
|
|
@@ -47,9 +47,9 @@
|
|
ifeq ($(ARCH), x86_64)
|
|
COMMON_CFLAGS+=-mno-red-zone
|
|
endif
|
|
-CFLAGS=$(COMMON_CFLAGS)
|
|
+CFLAGS=$(COMMON_CFLAGS) ${DEBUG_FLAGS}
|
|
MON_CFLAGS=$(COMMON_CFLAGS)
|
|
-KERNEL_CFLAGS=$(COMMON_CFLAGS)
|
|
+KERNEL_CFLAGS=$(COMMON_CFLAGS) ${DEBUG_FLAGS}
|
|
|
|
# Disable SSP if GCC supports it
|
|
MON_CFLAGS+=$(call cc-option,$(MON_CC),-fno-stack-protector,)
|
|
@@ -119,7 +119,7 @@
|
|
$(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c -o $@ $<
|
|
|
|
%.o: %.S
|
|
- $(CC) $(DEFINES) $(INCLUDES) -D__ASSEMBLY__ -c -o $@ $<
|
|
+ $(CC) ${DEBUG_FLAGS} $(DEFINES) $(INCLUDES) -D__ASSEMBLY__ -c -o $@ $<
|
|
|
|
clean:
|
|
rm -f *.o *~ monitor-image.h genoffsets genmon monitor_def.h \
|