freebsd-ports/multimedia/vdr-plugin-remote/files/patch-Makefile
Juergen Lock 47452dcb43 - Finally stagify the vdr ports. \o/
- Use new LIB_DEPENDS syntax.
- Change multimedia/vdr-plugins defaults and bump PORTREVISION for it.
  (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
2014-03-01 12:21:13 +00:00

48 lines
1.3 KiB
Text

--- a/Makefile
+++ b/Makefile
@@ -54,6 +54,12 @@ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I
DEFINES += -DREMOTE_FEATURE_LIRC
DEFINES += -DREMOTE_FEATURE_TCPIP
+ifeq ($(OSTYPE),FreeBSD)
+DEFINES += -DREMOTE_FEATURE_UHID
+else
+DEFINES += -DREMOTE_FEATURE_DEVINPUT
+endif
+
### The object files (add further files here):
OBJS = $(PLUGIN).o ttystatus.o
@@ -81,9 +87,9 @@ $(DEPFILE): Makefile
### Internationalization (I18N):
-ifneq ($(shell grep 'LOCALEDIR' $(VDRDIR)/Makefile),)
+#ifneq ($(shell grep 'LOCALEDIR' $(VDRDIR)/Makefile),)
PODIR = po
LOCALEDIR = $(VDRDIR)/locale
I18Npo = $(wildcard $(PODIR)/*.po)
I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
I18Ndirs = $(notdir $(foreach file, $(I18Npo), $(basename $(file))))
@@ -104,10 +110,10 @@ i18n: $(I18Nmo)
mkdir -p $(LOCALEDIR)/$$i/LC_MESSAGES;\
cp $(PODIR)/$$i.mo $(LOCALEDIR)/$$i/LC_MESSAGES/vdr-$(PLUGIN).mo;\
done
-else
-OBJS += i18n.o
-i18n: ;
-endif
+#else
+#OBJS += i18n.o
+#i18n: ;
+#endif
### Targets:
@@ -126,3 +132,6 @@ dist: clean
clean:
@-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
@-rm -f *.o $(DEPFILE) *.so *.tgz core* *~
+
+install:
+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)