- Asterisk project now embeds pjsip 2.10, get it's distribution from github and adapt port - Remove patch merged upstream - Refresh patches and rename to current naming scheme - Reorder some variables to silnce portlint warning
20 lines
866 B
Text
20 lines
866 B
Text
--- third-party/pjproject/Makefile.rules.orig 2020-07-09 15:39:17 UTC
|
|
+++ third-party/pjproject/Makefile.rules
|
|
@@ -7,7 +7,7 @@
|
|
# PACKAGE_URL ?= http://www.pjsip.org/release/$(PJPROJECT_VERSION)
|
|
|
|
PACKAGE_URL ?= https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/$(PJPROJECT_VERSION)
|
|
-TARBALL_FILE = pjproject-$(PJPROJECT_VERSION).tar.bz2
|
|
+TARBALL_FILE = pjsip-pjproject-$(PJPROJECT_VERSION)_GH0.tar.gz
|
|
|
|
# PJPROJECT_CONFIGURE_OPTS could come from the command line or could be
|
|
# set/modified by configure.m4 if the build or host tuples aren't the same
|
|
@@ -37,7 +37,7 @@ PJPROJECT_CONFIG_OPTS = $(PJPROJECT_CONFIGURE_OPTS) --
|
|
--disable-ipp \
|
|
--disable-libwebrtc \
|
|
--without-external-pa \
|
|
- --without-external-srtp
|
|
+ --with-external-srtp
|
|
|
|
ifneq ($(AST_DEVMODE),yes)
|
|
PJPROJECT_CONFIG_OPTS += --disable-resample --disable-g711-codec
|