freebsd-ports/archivers/libzip/files/patch-CMakeLists.txt
Dima Panov 8856ff5add archivers/libzip: update to 1.7.3
PR:		252456
Submitted by:	fluffy
Reported by:	Repology
Approved by:	rakuco
2021-01-06 16:09:13 +00:00

12 lines
424 B
Text

Do not set RPATH on FreeBSD either.
--- CMakeLists.txt.orig 2020-07-15 08:02:19 UTC
+++ CMakeLists.txt
@@ -237,7 +237,7 @@ if(WIN32)
endif(WIN32)
# rpath handling: use rpath in installed binaries
-if(NOT CMAKE_SYSTEM_NAME MATCHES Linux)
+if(NOT CMAKE_SYSTEM_NAME MATCHES "FreeBSD|Linux")
set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
endif()