51 lines
1.4 KiB
Text
51 lines
1.4 KiB
Text
Make build glue accept libpng 1.6.x and don't hardcode suffix
|
|
|
|
--- CMakeLists.txt.orig 2017-05-27 09:58:05 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -582,9 +582,10 @@ else()
|
|
set(LIBZIP_LIBRARY libzip)
|
|
endif()
|
|
|
|
-# FindPNG does a few things we don't want. So do it ourselves. Fixed to libpng17
|
|
-find_path(PNG_PNG_INCLUDE_DIR NAMES "libpng17/png.h")
|
|
-find_library(PNG_LIBRARY NAMES png17 libpng17)
|
|
+find_package(PkgConfig)
|
|
+pkg_check_modules(PNG libpng>=1.6)
|
|
+set(PNG_LIBRARY ${PNG_LIBRARIES})
|
|
+set(PNG_PNG_INCLUDE_DIR ${PNG_INCLUDE_DIRS})
|
|
find_package(PackageHandleStandardArgs)
|
|
find_package_handle_standard_args(PNG REQUIRED_VARS PNG_LIBRARY PNG_PNG_INCLUDE_DIR)
|
|
if (PNG_FOUND)
|
|
--- Core/Screenshot.cpp.orig 2017-05-27 09:58:05 UTC
|
|
+++ Core/Screenshot.cpp
|
|
@@ -21,7 +21,7 @@
|
|
#ifdef USING_QT_UI
|
|
#include <QtGui/QImage>
|
|
#else
|
|
-#include <libpng17/png.h>
|
|
+#include "png.h"
|
|
#include "ext/jpge/jpge.h"
|
|
#endif
|
|
|
|
--- ext/native/image/png_load.cpp.orig 2017-05-27 09:58:05 UTC
|
|
+++ ext/native/image/png_load.cpp
|
|
@@ -5,7 +5,7 @@
|
|
#ifdef USING_QT_UI
|
|
#include <QtGui/QImage>
|
|
#else
|
|
-#include "libpng17/png.h"
|
|
+#include "png.h"
|
|
#endif
|
|
|
|
#include "png_load.h"
|
|
--- Core/TextureReplacer.cpp.orig 2017-05-27 09:58:05 UTC
|
|
+++ Core/TextureReplacer.cpp
|
|
@@ -16,7 +16,7 @@
|
|
// https://github.com/hrydgard/ppsspp and http://www.ppsspp.org/.
|
|
|
|
#ifndef USING_QT_UI
|
|
-#include <libpng17/png.h>
|
|
+#include "png.h"
|
|
#endif
|
|
|
|
#include <algorithm>
|