37 lines
1.4 KiB
Text
37 lines
1.4 KiB
Text
--- src/Makefile.orig Wed Mar 3 18:55:57 1999
|
|
+++ src/Makefile Sat Mar 6 19:51:31 2004
|
|
@@ -26,19 +26,19 @@
|
|
# not all Unix C preprocessors define it.
|
|
# If your cpp is too fussy, make tools/clprepro and use this:
|
|
# CPP=../../src/tools/clprepro -Dunix
|
|
-CPP=/lib/cpp -P -traditional -Dunix
|
|
+CPP=/usr/bin/cpp -P -traditional -Dunix
|
|
|
|
# The directory where public executables will be installed
|
|
-BINDIR=/usr/local/bin
|
|
+BINDIR=${PREFIX}/bin
|
|
|
|
# The directory where the Caml Light standard library will be installed
|
|
-LIBDIR=/usr/local/lib/caml-light
|
|
+LIBDIR=${PREFIX}/lib/caml-light
|
|
|
|
# The manual section where the manual pages will be installed
|
|
MANEXT=1
|
|
|
|
# The directory where the manual pages will be installed
|
|
-MANDIR=/usr/local/man/man$(MANEXT)
|
|
+MANDIR=${PREFIX}/man/man$(MANEXT)
|
|
|
|
# Some "make"s need this to ensure that they call the Bourne shell,
|
|
# not the C shell. Seems harmless on most other "make"s.
|
|
@@ -120,8 +120,8 @@
|
|
|
|
# Install the Caml Light system
|
|
install:
|
|
- if test -d $(BINDIR); then : ; else mkdir $(BINDIR); fi
|
|
- if test -d $(LIBDIR); then : ; else mkdir $(LIBDIR); fi
|
|
+ if test -d $(BINDIR); then : ; else mkdir -p $(BINDIR); fi
|
|
+ if test -d $(LIBDIR); then : ; else mkdir -p $(LIBDIR); fi
|
|
cd runtime; make BINDIR=$(BINDIR) LIBDIR=$(LIBDIR) install
|
|
cd launch; make BINDIR=$(BINDIR) LIBDIR=$(LIBDIR) install
|
|
cd lib; make BINDIR=$(BINDIR) LIBDIR=$(LIBDIR) install
|