224eb510f9
1) fix 'indent -npro -nip' when compiled with BERKELEY_DEFAULTS symptom: command line: unknown option "nhnl" Note that the "nhnl" above is just luck due to layout by the compiler. It could be random garbage. explanation: PRO_SETTINGS lists need to be terminated with two nulls. 2) fix error message for args prefixed with '--', like 'indent -npro --no-such-arg' symptom: command line: unknown option "-no-such-arg" explanation: the error message uses 'option - 1' instead of 'option - option_length' and -- options have option_length == 2. Note that the update looks more complicated than just this patch, because the original port patches were re-aligned as well. John has submitted his patches upstream as well. Submitted by: John Hein <jhein@symmetricom.com> Feature safe: yes
17 lines
496 B
Text
17 lines
496 B
Text
--- doc/Makefile.in.orig 2008-03-11 19:54:15.000000000 +0100
|
|
+++ doc/Makefile.in 2010-06-27 16:29:17.000000000 +0200
|
|
@@ -602,10 +602,10 @@
|
|
uninstall-pdf-am uninstall-ps-am
|
|
|
|
|
|
-all-local: html
|
|
-install-data-local: install-html
|
|
-installdirs-local: installdirs-html
|
|
-uninstall-local: uninstall-html
|
|
+all-local: # html
|
|
+install-data-local: # install-html
|
|
+installdirs-local: # installdirs-html
|
|
+uninstall-local: # uninstall-html
|
|
|
|
html: html-$(HTMLSTYLE)
|
|
install-html: install-html-$(HTMLSTYLE)
|