fc8d424c6b
preparatory step to convert bsd.python.mk into a USES file. - Remove the shared/static build separation, which is the source of many problems and even more hacks. Instead build only the shared version, which greatly simplifies the build. - Remove the FPECTL option to align the build with the clean "template" from lang/python34. - Remove support for GNU pthreads via the PTH option. It is a permanent troublemaker for ports using Python and pthread support. - Remove PORTDATA and EXAMPLES. Those will be made available via separate ports. - Add a new DEBUG option to enable debug builds as for lang/python34. - Remove bin/smtpd. Only Python2.7 wants to install it, but we'd like to keep it consistent with the other lang/pythonXX ports - Add CPE support. - Reactivate curses/ncurses support. - Use buildbottest in the regression-test: target. - Move pkg-message to the right place. Phabric: D488 Exp-run: 192242, 192244 Reviewed by: koobs With hat: python@
30 lines
1.2 KiB
Python
30 lines
1.2 KiB
Python
# Description: SEM option patch. If SEM is enabled, enable the build properly
|
|
# Not upstreamed
|
|
|
|
--- setup.py.orig 2013-04-07 11:07:43.000000000 +0400
|
|
+++ setup.py 2013-04-07 11:16:36.000000000 +0400
|
|
@@ -1551,10 +1551,22 @@
|
|
macros = dict()
|
|
libraries = []
|
|
|
|
- elif host_platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'freebsd11'):
|
|
+ elif host_platform in ('freebsd4', 'freebsd5', 'freebsd6'):
|
|
# FreeBSD's P1003.1b semaphore support is very experimental
|
|
# and has many known problems. (as of June 2008)
|
|
- macros = dict()
|
|
+ macros = dict( # FreeBSD 4-6
|
|
+ HAVE_SEM_OPEN=0,
|
|
+ HAVE_SEM_TIMEDWAIT=0,
|
|
+ HAVE_FD_TRANSFER=1,
|
|
+ )
|
|
+ libraries = []
|
|
+
|
|
+ elif host_platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'freebsd11'):
|
|
+ macros = dict( # FreeBSD 7+
|
|
+ HAVE_SEM_OPEN=1,
|
|
+ HAVE_SEM_TIMEDWAIT=1,
|
|
+ HAVE_FD_TRANSFER=1,
|
|
+ )
|
|
libraries = []
|
|
|
|
elif host_platform.startswith('openbsd'):
|