freebsd-ports/devel/cocktail/files/patch-specs-c-c-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

49 lines
1.3 KiB
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./specs/c/c/Makefile Tue Feb 15 14:28:24 1994
+++ ./specs/c/c/Makefile Wed Aug 25 11:55:26 2004
@@ -1,23 +1,24 @@
-LIB = $(HOME)/lib
-INCDIR = $(LIB)/include
-CFLAGS = -I$(INCDIR) -g
-CC = cc
+ROOTDIR= ../../..
+.include "../../Makefile.inc"
+
+CFLAGS = $(TCFLAGS) -I $(TMPINC)
+
OBJS = ParserDrv.o Scanner.o Parser.o Positions.o Errors.o hash.o name-space.o
ParserDrv: $(OBJS)
- $(CC) $(CFLAGS) -o ParserDrv $(OBJS) $(LIB)/libreuse.a
+ $(CC) $(CFLAGS) -o ParserDrv $(OBJS) -L $(TMPLIB) -lreuse
Scanner.rpp Parser.lalr: c.pars
- lpp -cxzj c.pars;
+ $(LPP) -cxzj c.pars;
c.rex: c.scan Scanner.rpp
- rpp < c.scan > c.rex;
+ $(RPP) < c.scan > c.rex;
Scanner.h Scanner.c: c.rex
- rex -cd c.rex;
+ $(REX) -cd c.rex;
Parser.h Parser.c Errors.h Errors.c ParserDrv.c: Parser.lalr
- lalr -c -d -e -p -cs Parser.lalr;
+ $(LALR) -c -d -e -p -cs Parser.lalr;
ParserDrv.o: Parser.h Scanner.h
Parser.o: Parser.h Scanner.h Errors.h
@@ -29,10 +30,7 @@
lint -I$(INCDIR) -b -u *.c
clean:
- rm -f ParserDrv core *.o _Debug Parser.[hc] Scanner.[hc] Errors.[hc] \
+ -rm -f $(STDCLEAN)
+ -rm -f ParserDrv *.o _Debug Parser.[hc] Scanner.[hc] Errors.[hc] \
c.rex Parser.lalr Scanner.rpp ParserDrv.c
-.SUFFIXES: .c .o
-
-.c.o:
- $(CC) $(CFLAGS) -c $*.c