8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
44 lines
1.3 KiB
Text
44 lines
1.3 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./specs/modula/wag/Makefile Tue Feb 15 14:29:10 1994
|
|
+++ ./specs/modula/wag/Makefile Wed Aug 25 11:42:24 2004
|
|
@@ -18,29 +18,31 @@
|
|
lpp -xzj minilax.pars;
|
|
|
|
minilax.rex: minilax.scan Scanner.rpp
|
|
- rpp < minilax.scan > minilax.rex;
|
|
+ $(RPP) < minilax.scan > minilax.rex;
|
|
|
|
Scanner.md Scanner.mi: minilax.rex
|
|
- rex -d minilax.rex;
|
|
+ $(REX) -d minilax.rex;
|
|
|
|
Parser.md Parser.mi: Parser.lalr
|
|
- lalr -d Parser.lalr;
|
|
+ $(LALR) -d Parser.lalr;
|
|
|
|
Tree.md Tree.mi: minilax.cg
|
|
- cg -dimRDIL minilax.cg;
|
|
+ $(CG) -dimRDIL minilax.cg;
|
|
|
|
Semantics.md Semantics.mi: minilax.cg
|
|
- cg -DIL minilax.cg;
|
|
+ $(CG) -DIL minilax.cg;
|
|
|
|
Tree.TS: minilax.cg
|
|
- echo SELECT AbstractSyntax Output | cat - minilax.cg | cg -4
|
|
+ echo SELECT AbstractSyntax Output | cat - minilax.cg | $(CG) -4
|
|
|
|
Types.md Types.mi: Types.puma Tree.TS
|
|
- puma -dipk Types.puma;
|
|
+ $(PUMA) -dipk Types.puma;
|
|
|
|
ICode.md ICode.mi: ICode.puma Tree.TS
|
|
- puma -di ICode.puma;
|
|
+ $(PUMA) -di ICode.puma;
|
|
|
|
clean:
|
|
- rm -f Scanner.m? Parser.m? Tree.m? Semantics.m? Types.m? ICode.m? *.TS *.bak
|
|
- rm -f core *.[dimor] _Debug minilax minilax.rex Parser.lalr Scanner.rpp
|
|
+ -rm -f Scanner.m? Parser.m? Tree.m? Semantics.m? Types.m? ICode.m? *.TS *.bak
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.[dimor] _Debug minilax minilax.rex Parser.lalr Scanner.rpp
|
|
+.include "../../Makefile.inc"
|