freebsd-ports/x11-toolkits/py-wxPython28/files/patch-ac
2003-04-17 15:22:45 +00:00

111 lines
3.6 KiB
Text

$FreeBSD$
--- setup.py.orig Fri Mar 21 01:49:39 2003
+++ setup.py Fri Apr 18 18:02:09 2003
@@ -152,6 +152,16 @@
#----------------------------------------------------------------------
+# Check for some environment variables
+#----------------------------------------------------------------------
+
+try: gtk_config = os.environ['GTK_CONFIG']
+except KeyError: gtk_config = 'gtk-config'
+
+try: sys_libs = os.environ['LIBS'].split()
+except KeyError: sys_libs = []
+
+#----------------------------------------------------------------------
# Check for build flags on the command line
#----------------------------------------------------------------------
@@ -434,7 +444,7 @@
if WXPORT == 'gtk':
WXPLAT = '__WXGTK__'
- portcfg = os.popen('gtk-config --cflags', 'r').read()[:-1]
+ portcfg = os.popen(gtk_config + ' --cflags', 'r').read()[:-1]
elif WXPORT == 'gtk2':
WXPLAT = '__WXGTK__'
GENDIR = 'gtk' # no code differences so use the same generated sources
@@ -457,6 +467,7 @@
libdirs = []
libs = []
+ libs.extend(sys_libs)
Verify_WX_CONFIG()
@@ -691,8 +702,8 @@
if BUILD_OGL:
msg('Preparing OGL...')
location = 'contrib/ogl'
- OGLLOC = opj(location, 'contrib/src/ogl')
- OGLINC = opj(location, 'contrib/include')
+ OGLLOC = opj(location, '../../../contrib/src/ogl')
+ OGLINC = opj(location, '../../../contrib/include')
swig_files = ['ogl.i', 'oglbasic.i', 'oglshapes.i', 'oglshapes2.i',
'oglcanvas.i']
@@ -740,9 +751,9 @@
if BUILD_STC:
msg('Preparing STC...')
location = 'contrib/stc'
- STCLOC = opj(location, 'contrib/src/stc')
- STCINC = opj(location, 'contrib/include')
- STC_H = opj(location, 'contrib/include/wx/stc')
+ STCLOC = opj(location, '../../../contrib/src/stc')
+ STCINC = opj(location, '../../../contrib/include')
+ STC_H = opj(location, '../../../contrib/include/wx/stc')
if IN_CVS_TREE:
# Check if gen_iface needs to be run for the wxSTC sources
@@ -885,8 +896,8 @@
if BUILD_XRC:
msg('Preparing XRC...')
location = 'contrib/xrc'
- XMLLOC = opj(location, 'contrib/src/xrc')
- XMLINC = opj(location, 'contrib/include')
+ XMLLOC = opj(location, '../../../contrib/src/xrc')
+ XMLINC = opj(location, '../../../contrib/include')
swig_files = ['xrc.i']
@@ -974,8 +985,8 @@
if BUILD_GIZMOS:
msg('Preparing GIZMOS...')
location = 'contrib/gizmos'
- GIZMOLOC = opj(location, 'contrib/src/gizmos')
- GIZMOINC = opj(location, 'contrib/include')
+ GIZMOLOC = opj(location, '../../../contrib/src/gizmos')
+ GIZMOINC = opj(location, '../../../contrib/include')
swig_files = ['gizmos.i']
@@ -1052,8 +1063,8 @@
if BUILD_CANVAS:
msg('Preparing CANVAS...')
location = 'contrib/canvas'
- CANVASLOC = opj(location, 'contrib/src/canvas')
- CANVASINC = opj(location, 'contrib/include')
+ CANVASLOC = opj(location, '../../../contrib/src/canvas')
+ CANVASINC = opj(location, '../../../contrib/include')
swig_files = ['canvas.i']
@@ -1091,10 +1102,10 @@
if BUILD_ART2D:
msg('Preparing ART2D...')
location = 'contrib/art2d'
- ART2DLOC = opj(location, 'modules/canvas/src')
- ART2DINC = opj(location, 'modules/canvas/include')
- EXPATLOC = opj(location, 'modules/expat')
- EXPATINC = opj(location, 'modules/expat/include')
+ ART2DLOC = opj(location, '../../../modules/canvas/src')
+ ART2DINC = opj(location, '../../../modules/canvas/include')
+ EXPATLOC = opj(location, '../../../modules/expat')
+ EXPATINC = opj(location, '../../../modules/expat/include')
swig_files = ['art2d.i',
'art2d_misc.i',