freebsd-ports/net/yate/files/patch-Makefile.in
Michael Scheidell 6c964d8e8d - Update to 4.0.0.p1
- Update adds: SS7 components for mobile operators, T.38 fax, TCP and TLS support for SIP

PR:		ports/165552
Submitted by:	Valery Komarov <komarov@valerka.net> (maintainer)
Approved by:	gabor (mentor, implicit)
2012-02-29 21:50:53 +00:00

46 lines
1.5 KiB
Text

--- ./Makefile.in.orig 2012-02-10 19:22:46.000000000 +0400
+++ ./Makefile.in 2012-02-29 19:31:18.000000000 +0400
@@ -20,7 +20,7 @@
MKDEPS := ./config.status
PROGS:= yate
YLIB := libyate.so.@PACKAGE_VERSION@
-SLIBS:= $(YLIB) libyate.so \
+SLIBS:= $(YLIB) libyate.so libyate.so.4 \
libyatescript.so.@PACKAGE_VERSION@ libyatescript.so \
libyatesig.so.@PACKAGE_VERSION@ libyatesig.so \
libyatemgcp.so.@PACKAGE_VERSION@ libyatemgcp.so \
@@ -48,7 +48,7 @@
libdir = @libdir@
incdir = @includedir@/yate
mandir = @mandir@
-docdir = @datadir@/doc/yate-@PACKAGE_VERSION@
+docdir = @datadir@/doc/yate
vardir = @localstatedir@/lib/yate
moddir = @libdir@/yate
shrdir = $(datadir)/yate
@@ -222,7 +222,7 @@
install -m 0644 @srcdir@/docs/man/$$i "$(DESTDIR)$(mandir)/man8/" ; \
done
@mkdir -p "$(DESTDIR)$(libdir)/pkgconfig/" && \
- install -m 0644 yate.pc "$(DESTDIR)$(libdir)/pkgconfig/"
+ install -m 0644 yate.pc "$(DESTDIR)$(libdir)data/pkgconfig/"
@mkdir -p "$(DESTDIR)$(incdir)/" && \
for i in $(INCS) ; do \
install -m 0644 @srcdir@/$$i "$(DESTDIR)$(incdir)/" ; \
@@ -250,7 +250,7 @@
@-for i in $(PROGS) yate-config ; do \
rm "$(DESTDIR)$(bindir)/$$i" ; \
done
- @-rm "$(DESTDIR)$(libdir)/pkgconfig/yate.pc" && \
+ @-rm "$(DESTDIR)$(libdir)data/pkgconfig/yate.pc" && \
rmdir $(DESTDIR)$(libdir)/pkgconfig
@-for i in $(INCS) $(GENS) ; do \
rm "$(DESTDIR)$(incdir)/$$i" ; \
@@ -325,6 +325,7 @@
libyate.so: $(YLIB)
ln -sf $^ $@
+ ln -sf $^ $@\.4
.PHONY: library
library $(YLIB): yatepaths.h