freebsd-ports/x11-toolkits/tk80/files/patch-aa
Chris Timmons 4e2642a1b0 Tk 8.0.5
1999-04-30 16:11:52 +00:00

37 lines
1.5 KiB
Text

--- configure.orig Mon Mar 8 22:53:50 1999
+++ configure Thu Apr 29 11:23:44 1999
@@ -874,14 +874,14 @@
withval="$with_tcl"
TCL_BIN_DIR=$withval
else
- TCL_BIN_DIR=`cd ../../tcl8.0$TK_PATCH_LEVEL/unix; pwd`
+ TCL_BIN_DIR=${prefix}/lib/tcl8.0
fi
if test ! -d $TCL_BIN_DIR; then
{ echo "configure: error: Tcl directory $TCL_BIN_DIR doesn't exist" 1>&2; exit 1; }
fi
-if test ! -f $TCL_BIN_DIR/Makefile; then
- { echo "configure: error: There's no Makefile in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
+if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
+ { echo "configure: error: There's no tclConfig.sh in $TCL_BIN_DIR; perhaps your Tcl installation has been corrupted. Verify the installation of Tcl8.0 and try again." 1>&2; exit 1; }
fi
#--------------------------------------------------------------------
@@ -921,6 +921,7 @@
CFLAGS_DEBUG=$TCL_CFLAGS_DEBUG
CFLAGS_OPTIMIZE=$TCL_CFLAGS_OPTIMIZE
EXTRA_CFLAGS=$TCL_EXTRA_CFLAGS
+TCL_SRC_DIR=${prefix}/include/tcl${TCL_VERSION}
LIB_RUNTIME_DIR='${LIB_RUNTIME_DIR}'
@@ -2387,7 +2388,7 @@
if test "$ok" = "yes" -a "${SHLIB_SUFFIX}" != ""; then
TK_SHARED_BUILD=1
TK_SHLIB_CFLAGS="${SHLIB_CFLAGS}"
- TK_LIB_FILE=libtk${TCL_SHARED_LIB_SUFFIX}
+ TK_LIB_FILE=${TK_LIB_FILE}
MAKE_LIB="\${SHLIB_LD} -o \${TK_LIB_FILE} \${OBJS} \$(TK_LD_SEARCH_FLAGS) ${SHLIB_LD_LIBS}"
RANLIB=":"
else