60 lines
1.3 KiB
Text
60 lines
1.3 KiB
Text
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -42,6 +42,9 @@ TMPDIR ?= /tmp
|
|
|
|
-include $(VDRDIR)/Make.config
|
|
|
|
+# libc++
|
|
+CXXFLAGS+= -std=c++11
|
|
+
|
|
### The version number of VDR's plugin API (taken from VDR's "config.h"):
|
|
|
|
APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
|
|
--- a/css/Makefile
|
|
+++ b/css/Makefile
|
|
@@ -27,6 +27,9 @@ VDRDIR ?= ../../../..
|
|
|
|
-include $(VDRDIR)/Make.config
|
|
|
|
+# libc++
|
|
+CXXFLAGS+= -std=c++11
|
|
+
|
|
### Includes and Defines (add further entries here):
|
|
|
|
INCLUDES += -I$(VDRDIR)/include -I..
|
|
--- a/httpd/Makefile
|
|
+++ b/httpd/Makefile
|
|
@@ -5,6 +5,9 @@ CXXFLAGS ?= -O2 -Woverloaded-virtual -Wa
|
|
|
|
CXXFLAGS += `tntnet-config --cxxflags`
|
|
|
|
+# libc++
|
|
+CXXFLAGS+= -std=c++11
|
|
+
|
|
### Includes and Defines (add further entries here):
|
|
|
|
INCLUDES += -I.
|
|
--- a/javascript/Makefile
|
|
+++ b/javascript/Makefile
|
|
@@ -27,6 +27,9 @@ VDRDIR ?= ../../../..
|
|
|
|
-include $(VDRDIR)/Make.config
|
|
|
|
+# libc++
|
|
+CXXFLAGS+= -std=c++11
|
|
+
|
|
### Includes and Defines (add further entries here):
|
|
|
|
INCLUDES += -I$(VDRDIR)/include -I..
|
|
--- a/pages/Makefile
|
|
+++ b/pages/Makefile
|
|
@@ -27,6 +27,9 @@ VDRDIR = /usr/local/include/vdr
|
|
|
|
-include $(VDRDIR)/Make.config
|
|
|
|
+# libc++
|
|
+CXXFLAGS+= -std=c++11
|
|
+
|
|
### Includes and Defines (add further entries here):
|
|
|
|
INCLUDES += -I$(VDRDIR)/include -I..
|