freebsd-ports/mail/thunderbird/files/patch-mozilla-memory-jemalloc-Makefile.in
Beat Gaetzi c80e090095 - Update Firefox to 28.0
- Update Firefox ESR to 24.4.0
- Update Thunderbird to 24.4.0
- Update NSPR to 4.10.4
- Update NSS to 3.15.5
- Switch GSTREAMER option for non-esr ports to depend on
  multimedia/gstreamer1 [2]
- Switch to Uses/compiler.mk, defaults to lang/gcc47 on 8.x and 9.x
- Use port dependencies for libogg, libvorbis, libopus, harfbuzz, graphite2
- Enable readahead in url-classifier, asmjs, download resume like on Linux
- Build www/firefox and www/seamonkey faster using unified compilation
- Unbreak build on sparc64 [1]
- Workaround OPTIMIZED_CFLAGS startup crash on 8.x and 9.x
- OPTIMIZED_CFLAGS is enabled by default
- A few DEBUG build fixes
- Add clang 3.2/3.3/3.4 workarounds for i386
- Mention known GSTREAMER issue in pkg-message

Submitted by:	Jan Beich
PR:		ports/186580 [1]
Requested by:	kwm [2]
Security:	http://www.vuxml.org/freebsd/610de647-af8d-11e3-a25b-b4b52fce4ce8.html
2014-03-19 20:46:37 +00:00

10 lines
353 B
Text

--- mozilla/memory/jemalloc/Makefile.in~
+++ mozilla/memory/jemalloc/Makefile.in
@@ -12,3 +12,7 @@ include $(topsrcdir)/config/rules.mk
ifdef GNU_CC
CFLAGS += -std=gnu99
endif
+
+# XXX startup crash workaround for gcc47 on amd64
+jemalloc.$(OBJ_SUFFIX): OS_CFLAGS := $(filter-out -O3 -Ofast,$(OS_CFLAGS))
+jemalloc.$(OBJ_SUFFIX): MOZ_OPTIMIZE_FLAGS=