freebsd-ports/games/xvier/files/patch-xvier.c
Rusmir Dusko fd725de7e0 - Bump PORTREVISION
- Change master sites, add icon
- Take maintainership
- Remove DEPRECATED, EXPIRATION_DATE
- Add USE_CSTD=gnu89
- Support STAGEDIR
- Use PLIST_FILES instead of pkg-plist
- Add Desktop entry file
- Fix install with stage, use do-install
- Recreate patch with make makepatch, remove obsolete changes
- Add patches, fix bad C code
- Change pkg-descr
2014-03-30 13:59:07 +00:00

15 lines
400 B
C

--- ./xvier.c.orig 1992-07-29 02:04:33.000000000 +0200
+++ ./xvier.c 2014-03-30 13:14:36.798575126 +0200
@@ -5,10 +5,11 @@
#include <signal.h>
#include <sys/types.h>
#include <sys/time.h>
+#include <string.h>
#include "xvier.h"
-char *malloc();
+#include <stdlib.h> /* malloc, free, rand */
char *displayname = NULL, *geostring = NULL, *fontpattern = NULL;
int iconic = 0, level = 0;