freebsd-ports/devel/pwlib/files/patch-plugins-sound_esd-sound_esd.h
Pav Lucistnik 9b586f478b - Use a better way to detect SDL header
- Add WITH_ESOUND knob and enable the plugin build
- Fix bsdvideo (bktr(4)) plugin and make it buildable on more archs
- Add a small error handler to detect unresolved symbols in plugins
- Add more plugins to pkg-plist
- Add experimental support for firewire(4) based video devices.
  The segment of the Makefile is intentionally commented out.

PR:		ports/95422, ports/96624
Submitted by:	Joerg Pulz <Joerg.Pulz@frm2.tum.de>,
		Steve Ames <steve@energistic.com> (maintainer)
Approved by:	Steve Ames <steve@energistic.com> (maintainer)
2006-05-07 13:02:10 +00:00

22 lines
871 B
C

--- plugins/sound_esd/sound_esd.h.orig Thu Apr 6 16:47:28 2006
+++ plugins/sound_esd/sound_esd.h Thu Apr 6 16:48:06 2006
@@ -43,15 +43,15 @@
unsigned _bitsPerSample);
BOOL Setup();
BOOL Close();
- BOOL IsOpen() const;
+// BOOL IsOpen() const;
BOOL Write(const void * buf, PINDEX len);
BOOL Read(void * buf, PINDEX len);
BOOL SetFormat(unsigned numChannels,
unsigned sampleRate,
unsigned bitsPerSample);
- unsigned GetChannels() const;
- unsigned GetSampleRate() const;
- unsigned GetSampleSize() const;
+// unsigned GetChannels() const;
+// unsigned GetSampleRate() const;
+// unsigned GetSampleSize() const;
BOOL SetBuffers(PINDEX size, PINDEX count);
BOOL GetBuffers(PINDEX & size, PINDEX & count);
BOOL PlaySound(const PSound & sound, BOOL wait);