freebsd-ports/games/noegnud-slashem/files/patch-variants::Makefile
Pav Lucistnik b3ed5741b5 noeGNUd aims to be the ultimate User Interface ( UI ) for nethack. comibining
character mode, 2D tilesets and 3d graphics, all interchangeable at runtime to
allow the serious nethack player ultimate freedom of interface to the game that
allows ultimate freedom of gameplay and imagination.

noegnud-data is the foundamental data for noeGNUd which all noeGNUd games
depend on it. noegnud-nethack, noegnud-nethack-deet, noegnud-slashem, and
noegnud-littlehack are the four variant games that noeGNUd support.
noegnud-addons installs tilesets and sound themes.

PR:		ports/65318
Submitted by:	Leland Wang <llwang@infor.org>
2005-02-18 13:12:51 +00:00

51 lines
1.7 KiB
Text

--- variants/Makefile.orig Mon Nov 15 03:02:30 2004
+++ variants/Makefile Mon Nov 15 03:03:25 2004
@@ -1,7 +1,6 @@
NOEGNUDVERSION=noegnud-0.8.0
# you __MUST__ change this if you change the prefix for any variants' install !!!!!!!!!!!!!
# although ..... " make -e foo " also works :O ;)
-PREFIX = /usr/local
GAMEUID = games
GAMEGRP = bin
CHOWN = chown
@@ -62,31 +61,31 @@
install: install_all
install_nh342: nh342
- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2 install
install_nh343: nh343
- make -e -C $(NOEGNUDVERSION)-nethack-3.4.3 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.3 install
install_se006e4f8: se006e4f8
- make -e -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
install_se007e2: se007e2
- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
install_se007e5: se007e5
- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
install_se007e6: se007e6
- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
install_se007e6f2: se007e6f2
- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
install_lh001: lh001
- make -e -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
+ make -EPREFIX -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
install_nh342-dt: nh342-dt
- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
# data