freebsd-ports/graphics/fotoxx/files/patch-zfuncs.cc
Matthias Andree 92500c08eb Unbreak and upgrade to new upstream release 14.02.2.
Based on a patch to upgrade to 14.01.1 by Rainer Hurling,
based on a patch to upgrade to 13.03.1 by Rod Person.

Rainer's changes:
- new mastersite; 2nd mastersites contents has to be updated
- unbreak the port
- modernize LIB_DEPENDS
- support STAGE_DIR
- strip bin/fotoxx
- correct usage of desktop-file-utils
- update URL in pkg-descr
- update pkg-plist

Committer's changes:
- work around fetch(1)/nginx incompatibility making fetch commands with
  unmerged fix r261263 (and ancestors) unable to fetch from the primary
  site.
- add USES=pkgconfig
- add mirror sites
- fix installation of manfile
- fix paths in desktop file
- stop using xdg-desktop-menu for now, breaks the build and does not
  appear to be required

PR:		ports/177643
Submitted by:	Rod Person, Rainer Hurling
2014-02-07 01:01:37 +00:00

20 lines
783 B
C++

--- ./zfuncs.cc.orig 2014-02-05 20:42:34.000000000 +0100
+++ ./zfuncs.cc 2014-02-06 10:32:37.000000000 +0100
@@ -854,7 +854,7 @@
// A mutex lock is used to insure one thread at a time has access to the parameter.
// Many parameters can be used but there is only one mutex lock.
-mutex zget_lock = PTHREAD_MUTEX_INITIALIZER;
+mutex_tp zget_lock = PTHREAD_MUTEX_INITIALIZER;
int zget_locked(int &param) // lock and return parameter
{
@@ -1276,7 +1276,7 @@
namespace shell_asynch_names {
char *command[10];
int status[10];
- mutex mlock = PTHREAD_MUTEX_INITIALIZER;
+ mutex_tp mlock = PTHREAD_MUTEX_INITIALIZER;
}
int shell_asynch(cchar *Fcommand, ...) // v.5.5