freebsd-ports/net/pacemaker1/files/extra-patch-cts_remote.py
Vinícius Zavam 8e9f86e4ce net/pacemaker1: base ncurses, py37- support, and un-deprecate it
Makefiles
    - un-deprecate the port; bump PORTREVISION;
    - apply certain patches only if PYTHON_SUFFIX > 36;
    - use base system's ncurses instead of ports';

  pkg-plist: use %%PYTHON_SUFFIX%%, instead of its value

  files/*
    - extra*.py: https://docs.python.org/3/whatsnew/3.7.html
    - patch-tools_cibsecret.in: make proper use of `md5`

PR:		243944
Submitted by:	swills
2020-02-07 17:23:49 +00:00

11 lines
304 B
Python

--- cts/remote.py.orig 2020-02-07 14:06:22 UTC
+++ cts/remote.py
@@ -125,7 +125,7 @@ class RemoteExec:
'''
def __init__(self, rsh, silent=False):
- self.async = []
+ self.async_calls = []
self.rsh = rsh
self.silent = silent
self.logger = LogFactory()