freebsd-ports/www/analog/files/patch-aa
Michael Haro c5074a9159 use DOCSDIR
-- mharo

add -DHAVE_ZLIB to Makefile to use system libz and fix a bug
   -- Matthew Reimer <mreimer@vpop.net>

PR:		55844
Submitted by:	Matthew Reimer <mreimer@vpop.net>
2003-12-17 04:18:43 +00:00

41 lines
2.2 KiB
Text

--- src/Makefile.orig Sun Mar 23 05:57:02 2003
+++ src/Makefile Thu Aug 21 10:26:26 2003
@@ -2,15 +2,22 @@
# Please read docs/Readme.html, or <A HREF="http://www.analog.cx/">http://www.analog.cx/</A>
# This is a general Unix-like Makefile: Makefiles for other OS's can be found
# in the "build" directory.
-CC = gcc # which compiler to use: eg cc, acc, gcc. NB Different
+CC ?= gcc # which compiler to use: eg cc, acc, gcc. NB Different
# compilers need different CFLAGS, e.g., -O instead of -O2.
MAKE = make # which "make" to use
-CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
+CFLAGS += -I${LOCALBASE}/include -I${LOCALBASE}/include/gd
+#CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
# HP/UX cc needs CFLAGS = -Aa (HP/UX 9) or -Ae (HP/UX 10)
# BeOS needs CFLAGS = -O2 -Wl,-L/boot/home/config/lib
# BS2000/OSD needs CFLAGS = -XLLML -XLLMK
# NeXTSTEP needs CFLAGS = -O2 -pipe -no-precomp
-DEFS = # any combination of -DNOPIPES -DNODNS -DNODIRENT -DNOGLOB ...
+DEFS = -DLOGFILE=\"/var/log/httpd-access.log\" \
+ -DIMAGEDIR=\"/images/\" \
+ -DDEFAULTCONFIGFILE=\"$(PREFIX)/etc/analog.cfg\" \
+ -DLANGDIR=\"${PREFIX}/share/analog/lang/\" \
+ -DCONFIGDIR=\"$(PREFIX)/share/analog/\" \
+ -DHAVE_ZLIB
+#DEFS = # any combination of -DNOPIPES -DNODNS -DNODIRENT -DNOGLOB ...
# ... -DNOOPEN -DNOFOLLOW -DNOALARM -DNOGRAPHICS -DNOGMTIME ...
# ... -DEBCDIC -DUSE_PLAIN_SETJMP ...
# ... -DHAVE_GD -DHAVE_ZLIB -DHAVE_PCRE ...
@@ -30,6 +37,12 @@
OS = UNIX # Operating system: UNIX, DOS, WIN32, MAC, OS2, OSX, VMS
# RISCOS, BEOS, NEXTSTEP, MPEIX, BS2000, AS400, OS390
LIBS = -lm # extra libraries needed; most platforms (but not OS X or BeOS)
+
+.if !defined(WITHOUT_GD)
+DEFS+= -DHAVE_GD
+LIBS+= -L${LOCALBASE}/lib -lgd -lpng -ljpeg -lz
+.endif
+
# need -lm LAST
# if you defined HAVE_GD above you also need -lgd -lpng -ljpeg -lz
# if you defined HAVE_ZLIB above you also need -lz