47452dcb43
- Use new LIB_DEPENDS syntax. - Change multimedia/vdr-plugins defaults and bump PORTREVISION for it. (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
21 lines
585 B
Text
21 lines
585 B
Text
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -108,7 +108,11 @@ i18n: $(I18Nmsgs) $(I18Npot)
|
|
|
|
libvdr-$(PLUGIN).so: $(OBJS)
|
|
$(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
|
|
+ifdef FREEBSD
|
|
+ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
|
|
+else
|
|
@cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
|
|
+endif
|
|
|
|
dist: clean
|
|
@-rm -rf $(TMPDIR)/$(ARCHIVE)
|
|
@@ -120,3 +124,6 @@ dist: clean
|
|
|
|
clean:
|
|
@-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
|
|
+
|
|
+install:
|
|
+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
|