freebsd-ports/databases/rrdtool12/files/patch-bindings-Makefile.in
Jeremy Chadwick bc8a5d06bd Addition of databases/rrdtool12, for those of us who prefer to
use the previous release of RRDTool.

Also incorporate the CONFIGURE_TARGET changes (PR ports/126524).
2008-09-02 11:11:14 +00:00

24 lines
1.4 KiB
Text

--- ./bindings/Makefile.in.orig 2008-01-08 10:36:56.000000000 +0800
+++ ./bindings/Makefile.in 2008-01-08 10:38:18.000000000 +0800
@@ -544,9 +544,9 @@
all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
- test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
- test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
- test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+ test -f perl-piped/Makefile && cd perl-piped && $(MAKE) pure_install || true
+ test -f perl-shared/Makefile && cd perl-shared && $(MAKE) pure_install || true
+ test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) install || true
test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
# rules for buildung the ruby module
@@ -557,7 +557,7 @@
# rules for buildung the pyton module
python:
- cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
+ cd python && env INCDIR=../../src BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
# rules for building the perl module
perl_piped: perl-piped/Makefile