The following maintenance operations were performed: - Recreate all patches with `make makepatch` - Add LICENSE - Update MAINTAINER to kami@freebsd.org - games/ioquake3 - Replace a lot of `.if ${PORT_OPTIONS:MFOO}` with `bsd.options.mk` fu - Add support for slaves using different SDL versions - games/ioquake3-devel - Update to GIT revision 2808 - Use SDL2 - games/iourbanterror - Change treatment of patches so `make makepatch` doesn't screw the patches in ${MASTERDIR}/files over - Update 4.2.018 to 4.2.023 - games/urbanterror-data - Update 4.2.018 to 4.2.023 - Fix install without DOCS Reviewed by: cs Approved by: cs Differential Revision: https://reviews.freebsd.org/D5816
12 lines
385 B
C
12 lines
385 B
C
--- code/qcommon/qcommon.h.orig 2011-12-24 12:29:32 UTC
|
|
+++ code/qcommon/qcommon.h
|
|
@@ -1099,6 +1099,9 @@ char *Sys_DefaultInstallPath(void);
|
|
char *Sys_DefaultAppPath(void);
|
|
#endif
|
|
|
|
+void Sys_SetDefaultLibPath(const char *path);
|
|
+char *Sys_DefaultLibPath(void);
|
|
+
|
|
void Sys_SetDefaultHomePath(const char *path);
|
|
char *Sys_DefaultHomePath(void);
|
|
const char *Sys_TempPath(void);
|