37e4a0377f
- Support CFLAGS/ARCH properly - Support NOPORTDOCS Plus my own: - Remove ftp://... line from the comments section of Makefile - Adjust WWW line to be http:// instead of ftp:// PR: 18904 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
22 lines
810 B
Text
22 lines
810 B
Text
--- unix/Makefile.orig Sun Apr 16 12:27:18 2000
|
|
+++ unix/Makefile Wed May 31 03:30:22 2000
|
|
@@ -42,7 +42,7 @@
|
|
# such as -DDOSWILD).
|
|
|
|
# UnZip flags
|
|
-CC = cc# try using "gcc" target rather than changing this (CC and LD
|
|
+CC ?= cc# try using "gcc" target rather than changing this (CC and LD
|
|
LD = $(CC)# must match, else "unresolved symbol: ___main" is possible)
|
|
AS = as
|
|
LOC = $(LOCAL_UNZIP)
|
|
@@ -679,8 +679,8 @@
|
|
# FreeBSD on Intel:
|
|
freebsd: unix_make
|
|
@echo 'NOTE: use bsd target for non-Intel FreeBSD compiles (if any).'
|
|
- $(MAKE) unzips CC=gcc LD=gcc AS=gcc\
|
|
- CF="-O3 -Wall -I. -DASM_CRC -DBSD $(LOC)"\
|
|
+ $(MAKE) unzips CC=$(CC) LD=$(CC) AS=$(CC)\
|
|
+ CF="-I. -DASM_CRC -DBSD $(LOC)"\
|
|
AF="-Di386 $(AF)" CRC32=crc_gcc
|
|
|
|
# Generic BSDish Unix gcc. ``The -O3 only works with later versions of gcc;
|