apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
54 lines
1.8 KiB
Text
54 lines
1.8 KiB
Text
|
|
$FreeBSD$
|
|
|
|
--- control-center/Makefile.in.orig Wed Jul 10 16:48:34 2002
|
|
+++ control-center/Makefile.in Wed Jul 10 16:51:37 2002
|
|
@@ -208,7 +208,7 @@
|
|
sys_in_files = gnomecc.desktop.in
|
|
sys_DATA = $(sys_in_files:.desktop.in=.desktop)
|
|
|
|
-confexecdir = $(libdir)
|
|
+confexecdir = $(sysconfdir)
|
|
confexec_DATA = cappletConf.sh
|
|
|
|
libcapplet_la_SOURCES = \
|
|
@@ -218,7 +218,7 @@
|
|
$(CORBA_SRCLIST)
|
|
|
|
|
|
-libcapplet_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
|
|
+libcapplet_la_LDFLAGS = -version-info 5:0:0
|
|
libcapplet_la_LIBADD = $(ORB_LIBS) -lm $(DL_LIB) $(GNORBA_LIBS)
|
|
|
|
libcappletincludedir = $(includedir)/libcapplet1
|
|
@@ -522,12 +522,10 @@
|
|
check: check-am
|
|
installcheck-am:
|
|
installcheck: installcheck-am
|
|
-install-exec-am: install-libLTLIBRARIES install-binPROGRAMS \
|
|
- install-confexecDATA
|
|
+install-exec-am: install-binPROGRAMS
|
|
install-exec: install-exec-am
|
|
|
|
-install-data-am: install-appiconDATA install-splashDATA install-sysDATA \
|
|
- install-libcappletincludeHEADERS
|
|
+install-data-am: install-appiconDATA install-splashDATA install-sysDATA
|
|
install-data: install-data-am
|
|
|
|
install-am: all-am
|
|
@@ -546,7 +544,6 @@
|
|
$(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir) \
|
|
$(DESTDIR)$(appicondir) $(DESTDIR)$(confexecdir) \
|
|
$(DESTDIR)$(splashdir) $(DESTDIR)$(sysdir) \
|
|
- $(DESTDIR)$(libcappletincludedir)
|
|
|
|
|
|
mostlyclean-generic:
|
|
@@ -592,6 +589,7 @@
|
|
clean-libLTLIBRARIES maintainer-clean-libLTLIBRARIES \
|
|
uninstall-libLTLIBRARIES install-libLTLIBRARIES mostlyclean-compile \
|
|
distclean-compile clean-compile maintainer-clean-compile \
|
|
+ -e 's?\@VERSION\@?$(VERSION)?g' \
|
|
mostlyclean-libtool distclean-libtool clean-libtool \
|
|
maintainer-clean-libtool mostlyclean-binPROGRAMS distclean-binPROGRAMS \
|
|
clean-binPROGRAMS maintainer-clean-binPROGRAMS uninstall-binPROGRAMS \
|