freebsd-ports/misc/team/files/patch-a
David E. O'Brien 9f76c1d34b Merge all the patches together so there is one patch / souce file.
(there were more patch files than souce files here :) )

Now merged are the fixes:
ports/1966: Team doesn't support...

ports/2204: Team can hang when stderr is a file
I've seen team hang when stderr is a file.  'top' reports that it is
stuck in lockf.

ports/2203: Team's exit status doesn't indicate if there ...
Team's exit status will be 0 even if there is an I/O error.  The reason
is that the exit status of the "guys" isn't checked.

Submitted by:   dawes@physics.usyd.edu.au (David Dawes)
1998-03-15 20:43:16 +00:00

33 lines
562 B
Text

--- Makefile.dist Sat Jul 1 08:33:24 1995
+++ Makefile Sun Mar 15 12:37:16 1998
@@ -1,25 +1,8 @@
-CFLAGS =-O
-LDFLAGS =-s
+PROG= team
-INSTX =install -m 0755 -s
-INSTD =install -m 0644
+BINDIR= ${PREFIX}/bin
+MANDIR= ${PREFIX}/man/man
-DEST=
+CFLAGS+= -DHAVE_PARAM_H -DHAVE_WAIT_H
-MI =$(DEST)/usr/
-MD =$(DEST)/usr/
-
-M1X =1
-
-BIND =$(MD)bin/
-MANI =$(MI)man
-
-MANI1 =$(MANI)$(M1X)/
-
-all: team
-
-clean::
- rm -f team team.o
-
-$(BIND)team: team; $(INSTX) $? $@
-$(MANI1)team.$(M1X): team.1; $(INSTD) $? $@
+.include <bsd.prog.mk>