freebsd-ports/math/faiss/files/patch-tests_CMakeLists.txt
Yuri Victorovich c6c877853c math/{,py-}faiss: Update 1.7.3 → 1.7.4
Reported by:	portscout
2023-04-21 22:10:38 -07:00

13 lines
339 B
Text

- workaround for https://github.com/facebookresearch/faiss/issues/2827
--- tests/CMakeLists.txt.orig 2023-04-19 13:18:30 UTC
+++ tests/CMakeLists.txt
@@ -52,6 +52,8 @@ find_package(OpenMP REQUIRED)
target_link_libraries(faiss_test PRIVATE
OpenMP::OpenMP_CXX
gtest_main
+ gtest
+ pthread
)
# Defines `gtest_discover_tests()`.